Anunţ

Caută printre mesajele de pe forum înainte de a scrie unul nou!
Formulează corect întrebarea sau problema pe care o ai.
Respectă regulile forumului și Codul de Conduită!

#1 17 Mar 2014 23:20:42

Tibus
Membru
Înregistrat: 21 Oct 2007
Mesaje: 243
Site web

Instalare VLC 2.0.8 Ubuntu 14.04

Acum am vlc 2.1.2, vreau sa folosesc plugin-ul vlsub, acesta functioneaza doar pe versiuni mai vechi de 2.1.0.

Cum pot instala vlc 2.0.8 ?

Aici https://launchpad.net/~videolan/+archiv … /+packages apar si pachete de 2.0.8 pentru Ubuntu 13.10, poate merg si pe Ubuntu 14.04, sunt dispus sa incerc, chiar daca apar conflicte, dar nu stiu cum sa fac, nu vad unde sunt ppa-urile.

Editat ultima oară de Tibus (17 Mar 2014 23:21:01)

Offline

 

#2 17 Mar 2014 23:23:50

wladypauly
Membru
Locaţie: Pascani
Înregistrat: 14 Jun 2011
Mesaje: 4822
Site web

Re: Instalare VLC 2.0.8 Ubuntu 14.04


Răspunsul va fi pe măsura întrebării!
I am curious. Since I'm not a cat, that's not dangerous. House M.D.
(Adică ceva de genul „Curioșii mor repede, dar nu mor proști”)

Offline

 

#3 17 Mar 2014 23:47:08

Tibus
Membru
Înregistrat: 21 Oct 2007
Mesaje: 243
Site web

Re: Instalare VLC 2.0.8 Ubuntu 14.04

Am adaugat ppa-ul :

Cod:

sudo add-apt-repository ppa:videolan/stable-daily
sudo apt-get update

Am instalat vlc, acum mi-a pus 2.1.5 smile  Eu as vrea 2.0.8 care este pentru Ubuntu 13.10, se poate ?
Am incercat sa editez /etc/apt/sources.list.d/videolan-stable-daily-trusty.list , am schimbat din ppa trusty cu saucy, si mi-a bagat iar 2.1.2

Offline

 

#4 18 Mar 2014 15:10:27

wladypauly
Membru
Locaţie: Pascani
Înregistrat: 14 Jun 2011
Mesaje: 4822
Site web

Re: Instalare VLC 2.0.8 Ubuntu 14.04

Trebuie să faci downgrade. Cred că așa s-ar face:

Cod:

sudo apt-get purge vlc
 sudo apt-get install vlc=version

Schimbi version cu versiunea pe care o vrei. Problema este că va trebui să oprești vlc de la actualizare. Care se face cam așa:

Cod:

printf 'Package: vlc\nPin: version 2.0*\nPin-Priority: 1001\n' | sudo tee /etc/apt/preferences.d/vlc
 echo vlc hold | sudo dpkg --set-selections
sudo aptitude hold vlc #pasul ăsta cică n-ar fi obigatoriu, doar primele două

Răspunsul va fi pe măsura întrebării!
I am curious. Since I'm not a cat, that's not dangerous. House M.D.
(Adică ceva de genul „Curioșii mor repede, dar nu mor proști”)

Offline

 

#5 18 Mar 2014 22:30:04

Tibus
Membru
Înregistrat: 21 Oct 2007
Mesaje: 243
Site web

Re: Instalare VLC 2.0.8 Ubuntu 14.04

Multumesc, am reusit sa fac ce vroiam, dar se pare ca nu merge ::
In ppa pentru Ubuntu 14.04 exista doar vlc 2.1.2, din cate apare pe site, 2.0.8 este pentru Ubuntu 13.10 sau mai vechi...

Totusi am incercat : am editat in /etc/apt/sources.list.d/videolan-stable-daily-trusty.list , am schimbat din ppa trusty cu saucy, si ::

Cod:

 sudo apt-get install vlc=2.0.8+git20140305+r49188+13+8~ubuntu13.10.1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 2.0.8+git20140305+r49188+13+8~ubuntu13.10.1) but it is not going to be installed
       Depends: libavcodec53 (>= 6:0.8.3-1~) but it is not installable or
                libavcodec-extra-53 (>= 6:0.8.10) but it is not installable
       Depends: libavutil51 (>= 6:0.8.3-1~) but it is not installable or
                libavutil-extra-51 (>= 6:0.8.10) but it is not installable
       Depends: libvlccore5 (>= 2.0.0) but it is not going to be installed
       Recommends: vlc-plugin-notify (= 2.0.8+git20140305+r49188+13+8~ubuntu13.10.1) but it is not going to be installed
       Recommends: vlc-plugin-pulse (= 2.0.8+git20140305+r49188+13+8~ubuntu13.10.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Altceva nu cred ca mai am ce sa incerc...

Editat ultima oară de Tibus (18 Mar 2014 22:31:27)

Offline

 

#6 19 Mar 2014 12:34:22

xxvirusxx
Membru
Locaţie: Focșani
Înregistrat: 07 Sep 2013
Mesaje: 1013

Re: Instalare VLC 2.0.8 Ubuntu 14.04

@Tibus

Dar ce eroare da VLsub 0.9.10 de pe 2.12? Sau ce ar trebui sa faca si nu face?

Offline

 

#7 19 Mar 2014 15:03:39

Tibus
Membru
Înregistrat: 21 Oct 2007
Mesaje: 243
Site web

Re: Instalare VLC 2.0.8 Ubuntu 14.04

Zicea "cannot load lua extension" sau ceva asemanator....  Nu prea m-am interesat sa fac debugging pentru ca pe site-ul oficial de VLsub scrie asta :

Cod:

[b]/!\ Troubleshooting /!\[/b]

VLSub is not working with Vlc 2.1.0 (lastest stable version) on any platform because the lua "net" module needed to interact with opensubtitles has been removed in this release for the extensions.
Until the next release of Vlc you have to install an other version of Vlc (2.0.8 for example) to use Vlsub.

Imi era foarte folositor, porneam un film, intram in VLsub, apasam search + Download si gata si pornea automat noua subtitrare.

Editat ultima oară de Tibus (19 Mar 2014 15:05:39)

Offline

 
Feed

Antet forum

Powered by FluxBB