Anunţ

Caută printre mesajele de pe forum înainte de a scrie unul nou!
Formulează corect întrebarea sau problema pe care o ai.
Respectă regulile forumului și Codul de Conduită!

#1 31 Oct 2017 08:50:07

emenem
Membru
Înregistrat: 26 Feb 2011
Mesaje: 139

[REZOLVAT]O problema de placa de retea sau server

In ianuarie anul asta... am pus intreaga retea in spatele unui server pe Ubuntu 14.04.1 LTS. Am adaugat  a -2-a placa de retea serverului cu 192.168.2.0/24 avand interfata eth1 cu 192.168.2.1 (mai precis placa INTEL PRO/1000 CT 10/100/1000Base-T, Bulk, Ethernet). Apoi am conectat la placa de retea routerul wireless Gigabit TP-LINK TL-WR1043ND, la sfaturile cuiva l-am setat ca pe un switch wireless, i-am dat in lan ip-ul 192.168.2.2, am setat wireless-ul, i-am dat disable la dhcp. In server am setat dhcp-ul, firewalul etc si a mers ok.

Pe la jumatea lui septembrie pe wireless a inceput sa dea laptopurilor ip-uri din 192.168.0.1/24. La cateva resetari de retea ale respectivelor laptopurilor se rezolva problema. Dar aparea frecvent problema respectiva si aparea doar pe wireless. La un moment dat am zis sa inlocuiesc pe server 192.168.2.0/24 cu 192.168.1.0/24 dar n-am mers. Apoi  a urmat o perioada (de cel putin 3 saptamani) cand problema asta n-am mai aparut.

Ieri a aparut alta problema, routerul wireless nu s-a mai putut conecta la placa de retea, dadeam ping de pe un laptop catre 192.168.2.1 si nu mergea, trebuia sa-i setez un ip static laptopului ca nu primea ip prin dhcp. Am resetat routerul la setarile din fabrica, apoi l-am reconfigurat si n-a mers. L-am inlocuit cu un alt   Gigabit TP-LINK TL-WR1043ND si n-am mers. Am pus un TL-WR841N si n-a mers.

Ati mai intalnit asa ceva? E posibil sa fie o problema de placa de retea sau o problema hard a serverului? Sau poate o problema de configurare Ubuntu(desi eu din ianuarie nu a mai facut nicio schimbare)?

Update: am uitat sa specific ca daca conectez placa de retea direct la un laptop prin cablu fara sa fie vreun router wireless intre ele...atunci merge atat pe ip static cat si pe dhcp

Editat ultima oară de emenem (02 Nov 2017 13:51:08)

Offline

 

#2 01 Nov 2017 14:27:07

emenem
Membru
Înregistrat: 26 Feb 2011
Mesaje: 139

Re: [REZOLVAT]O problema de placa de retea sau server

Deci azi a inceput sa mearga, insa cand am reconectat un switch   pe 10/100 la portul lan al routerului a reaparut problema.
Acelasi lucru s-a intamplat cu un tp-link pe gigabit(insa el conectandu-se la vreo 25 de m prin cablu la acest router, in comparatie cu 1m la tenda) si problema a aparut din nou.

Am gasit niste logs

Cod:

Nov  1 09:13:36 hostname kernel: [76783.990575] irq 45: nobody cared (try booting with the "irqpoll" option)
Nov  1 09:13:36 hostname kernel: [76783.990997] CPU: 0 PID: 26280 Comm: grep Not tainted 3.13.0-32-generic #57-Ubuntu
Nov  1 09:13:36 hostname kernel: [76783.990999] Hardware name: ASUS All Series/H81M-A, BIOS 2201 03/09/2015
Nov  1 09:13:36 hostname kernel: [76783.991001]  00000000 00000000 f3409f54 c1650cd3 f695d0c0 f3409f74 c10a7999 c1830644
Nov  1 09:13:36 hostname kernel: [76783.991006]  0000002d f7bd44b4 c19702c0 f695d0c0 0000002d f3409f98 c10a7d93 00000000
Nov  1 09:13:36 hostname kernel: [76783.991010]  0000ded1 e3235ec0 012386eb f695d0c0 f695d114 00000000 f3409fd4 c10a5cd5
Nov  1 09:13:36 hostname kernel: [76783.991013] Call Trace:
Nov  1 09:13:36 hostname kernel: [76783.991020]  [<c1650cd3>] dump_stack+0x41/0x52
Nov  1 09:13:36 hostname kernel: [76783.991024]  [<c10a7999>] __report_bad_irq+0x29/0xd0
Nov  1 09:13:36 hostname kernel: [76783.991027]  [<c10a7d93>] note_interrupt+0x153/0x1a0
Nov  1 09:13:36 hostname kernel: [76783.991030]  [<c10a5cd5>] handle_irq_event_percpu+0xc5/0x1a0
Nov  1 09:13:36 hostname kernel: [76783.991032]  [<c10a5de1>] handle_irq_event+0x31/0x50
Nov  1 09:13:36 hostname kernel: [76783.991035]  [<c10a8080>] ? handle_simple_irq+0x70/0x70
Nov  1 09:13:36 hostname kernel: [76783.991038]  [<c10a80e6>] handle_edge_irq+0x66/0x110
Nov  1 09:13:36 hostname kernel: [76783.991039]  <IRQ>  [<c165f6ec>] ? do_IRQ+0x3c/0xb0
Nov  1 09:13:36 hostname kernel: [76783.991045]  [<c165f4b3>] ? common_interrupt+0x33/0x38
Nov  1 09:13:36 hostname kernel: [76783.991048]  [<c118655b>] ? do_last+0xe2b/0xf60
Nov  1 09:13:36 hostname kernel: [76783.991052]  [<c12a81fa>] ? apparmor_file_alloc_security+0x4a/0x130
Nov  1 09:13:36 hostname kernel: [76783.991056]  [<c1270514>] ? security_file_alloc+0x14/0x20
Nov  1 09:13:36 hostname kernel: [76783.991058]  [<c1186740>] ? path_openat+0xb0/0x520
Nov  1 09:13:36 hostname kernel: [76783.991060]  [<c1187761>] ? do_filp_open+0x31/0x80
Nov  1 09:13:36 hostname kernel: [76783.991064]  [<c11785e5>] ? do_sys_open+0x115/0x260
Nov  1 09:13:36 hostname kernel: [76783.991067]  [<c107a064>] ? __put_cred+0x34/0x40
Nov  1 09:13:36 hostname kernel: [76783.991070]  [<c1177c78>] ? SyS_access+0x188/0x1f0
Nov  1 09:13:36 hostname kernel: [76783.991072]  [<c1178752>] ? SyS_open+0x22/0x30
Nov  1 09:13:36 hostname kernel: [76783.991076]  [<c1657da7>] ? syscall_call+0x7/0xb
Nov  1 09:13:36 hostname kernel: [76783.991077] handlers:
Nov  1 09:13:36 hostname kernel: [76783.991504] [<f892e640>] e1000_msix_other [e1000e]
Nov  1 09:13:36 hostname kernel: [76783.991938] Disabling IRQ #45

Cu ethtool am gasit rx_missed_errors: 25997

Din ce am mai gasit pe net ar trebui sa am in /etc/default/grub

Cod:

   GRUB_CMDLINE_LINUX_DEFAULT="irqpoll"

Insa ce efecte poate avea?

Update: Problema s-a rezolvat dupa ce am dat reset la switch-ul gigabit si-a revenit(acel switch tenda nu cauza nicio problema, a fost o mica confuzie.
Practic topologia retelei este: server-->router-->switch gigabit.

Il voi marca ca fiind rezolvat subiectul, insa inca sunt in stare de alerta pentru ca e ciudat ca un switch  unmanaged sa blocheze chiar si conexiunea dintre router si server.

Editat ultima oară de emenem (02 Nov 2017 13:49:32)

Offline

 
Feed

Antet forum

Powered by FluxBB