Anunţ

Caută printre mesajele de pe forum înainte de a scrie unul nou!
Formulează corect întrebarea sau problema pe care o ai.
Respectă regulile forumului și Codul de Conduită!

#1 18 Aug 2019 21:19:32

DanielSS2001
Membru nou
Înregistrat: 03 Feb 2019
Mesaje: 6

Problema cu python idle3.6

Buna ziua!! Am o problema cu pythonul, idee este ca orice incerc sa fac cum ar fi spre exemplu sa instalez o aplictatie sau sa zicem ca rulez sudo apt-get upgrade sau sudo apt-get update imi da urmatoarea eroare : The following packages have unmet dependencies:
idle : Depends: idle-python3.6 but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Numai stiu ce sa mai fac, am incercat sa dezinstalez python, de aceiasi eroare ma izbesc. Am incercat sa instalez python3.7 la fel, aceiasi chestie.

Offline

 

#2 19 Aug 2019 14:26:07

Alexandru.Cucu
Administrator
Locaţie: -21.8021247, -154.6975949
Înregistrat: 17 Jun 2008
Mesaje: 6954
Site web

Re: Problema cu python idle3.6

Pai un posibil raspuns e chiar in mesajul de eroare:

sudo apt --fix-broken install

Offline

 

#3 20 Aug 2019 22:37:11

DanielSS2001
Membru nou
Înregistrat: 03 Feb 2019
Mesaje: 6

Re: Problema cu python idle3.6

Alexandru.Cucu a scris:

Pai un posibil raspuns e chiar in mesajul de eroare:

sudo apt --fix-broken install

Pai am rulat comanda, imi zice ca instaleaza idle--python3.6 dar merge ce merge si ajung la urmatoarea eroare :
trying to overwrite '/usr/lib/python3.6/idlelib/CREDITS.txt', which is also in package libpython3.6-stdlib:amd64 3.6.8-1+xenial1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/idle-python3.6_3.6.8-1~18.04.york0_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

No, apai de aici ce mai fac?? smile))

Offline

 

#4 21 Aug 2019 19:15:53

zBANG
Membru
Locaţie: Neamt
Înregistrat: 07 May 2015
Mesaje: 91

Re: Problema cu python idle3.6

1)incearca cu :
sudo su
apt--fix-broken install

2) sudo su
apt update --fix-missing
apt install -f


Gaming is fun...banggin' is funnier !!

Offline

 

#5 22 Aug 2019 14:34:43

Alexandru.Cucu
Administrator
Locaţie: -21.8021247, -154.6975949
Înregistrat: 17 Jun 2008
Mesaje: 6954
Site web

Re: Problema cu python idle3.6

Ai un PPA din care instalezi idle-python3.6, nu-i asa?
Aparent idle e deja instalat deja din alt pachet pentru ca vrea sa suprascrie fisiere din pachetul libpython3.6-stdlib.

Offline

 

#6 24 Aug 2019 08:26:29

DanielSS2001
Membru nou
Înregistrat: 03 Feb 2019
Mesaje: 6

Re: Problema cu python idle3.6

Alexandru.Cucu a scris:

Ai un PPA din care instalezi idle-python3.6, nu-i asa?
Aparent idle e deja instalat deja din alt pachet pentru ca vrea sa suprascrie fisiere din pachetul libpython3.6-stdlib.

Asa este, instalez dintr-un ppa si ma izbesc de eroarea asta pe care am mentionat-o in raspuns. Ce ar trebui sa fac ?? Sau macar unde as putea gasi informatii despre aceste pachete??

Offline

 

#7 24 Aug 2019 08:27:53

DanielSS2001
Membru nou
Înregistrat: 03 Feb 2019
Mesaje: 6

Re: Problema cu python idle3.6

zBANG a scris:

1)incearca cu :
sudo su
apt--fix-broken install

2) sudo su
apt update --fix-missing
apt install -f

de aceiasi eroare ma lovesc, la 2) merge totul bine pana la apt install  de acolo ma lovesc de eroarea mentionata si anume
Unpacking idle-python3.6 (3.6.8-1~18.04.york0) ...
dpkg: error processing archive /var/cache/apt/archives/idle-python3.6_3.6.8-1~18.04.york0_all.deb (--unpack):
trying to overwrite '/usr/lib/python3.6/idlelib/CREDITS.txt', which is also in package libpython3.6-stdlib:amd64 3.6.8-1+xenial1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/idle-python3.6_3.6.8-1~18.04.york0_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Mai departe cum procedez??

Offline

 
Feed

Antet forum

Powered by FluxBB