Anunţ

Caută printre mesajele de pe forum înainte de a scrie unul nou!
Formulează corect întrebarea sau problema pe care o ai.
Respectă regulile forumului și Codul de Conduită!

#1 05 Oct 2006 03:23:05

alecsx
Membru
Locaţie: Tg Mures
Înregistrat: 02 Mar 2006
Mesaje: 46
Site web

Software index is Broken.....!

HY tuturor !
AM incercat sa instalez Ymessenger (nu stiu de ce),iar datorita faptului ca necesita niste librarii am inceput sa instalez acele librarii care solicitau la randul lor alte librarii,pana am ajuns la tzdata.


alex@Ubuntu:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
  libc6: Depends: tzdata but it is not installable
  libc6-i686: PreDepends: libc6 (= 2.3.6-0ubuntu20) but 2.3.6.ds1-4 is installed  ymessenger: Depends: xlibs (> 3.3.6) but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
alex@Ubuntu:~$



.Am incercat  si din recovery cu sudo apt-get -f install , insa aceiasi eroare .
Poate cineva sa imi dea o sugestie ....

Va Multumesc Anticipat!


[root@cust-rtr-idu-26 /]# kill bill
bash: kill: bill: arguments must be process or job IDs
-------------------------------------------------------------------
www.easyhowto.eu

Offline

 

#2 05 Oct 2006 04:30:57

sebastian
Administrator
Locaţie: Shanghai / Timisoara
Înregistrat: 31 Jul 2005
Mesaje: 616

Re: Software index is Broken.....!

deinstaleaza pachetele ce le-ai instalat anterior
sau foloseste --fix-broken
man apt-get pentru usage

Offline

 

#3 05 Oct 2006 12:37:08

alecsx
Membru
Locaţie: Tg Mures
Înregistrat: 02 Mar 2006
Mesaje: 46
Site web

Re: Software index is Broken.....!

Am incercat si inainte .....insa  nu reusesc nicicum

alex@Ubuntu:~$ sudo apt-get remove ymessenger
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  libc6: Depends: tzdata but it is not installable
  libc6-i686: PreDepends: libc6 (= 2.3.6-0ubuntu20) but 2.3.6.ds1-4 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
alex@Ubuntu:~$ sudo apt-get remove tzdata
Reading package lists... Done
Building dependency tree... Done
Package tzdata is not installed, so not removed
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  libc6: Depends: tzdata but it is not installable
  libc6-i686: PreDepends: libc6 (= 2.3.6-0ubuntu20) but 2.3.6.ds1-4 is to be installed
  ymessenger: Depends: xlibs (> 3.3.6) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
alex@Ubuntu:~$ sudo apt-get remove libc6-i686
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  libc6: Depends: tzdata but it is not installable
  ubuntu-minimal: Depends: libc6-i686 but it is not going to be installed
  ymessenger: Depends: xlibs (> 3.3.6) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
alex@Ubuntu:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
  libc6: Depends: tzdata but it is not installable
  libc6-i686: PreDepends: libc6 (= 2.3.6-0ubuntu20) but 2.3.6.ds1-4 is installed
  ymessenger: Depends: xlibs (> 3.3.6) but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
alex@Ubuntu:~$


ce as mai putea face ?


[root@cust-rtr-idu-26 /]# kill bill
bash: kill: bill: arguments must be process or job IDs
-------------------------------------------------------------------
www.easyhowto.eu

Offline

 

#4 05 Oct 2006 13:35:36

[sc]
Membru nou
Înregistrat: 03 Oct 2006
Mesaje: 14

Re: Software index is Broken.....!

am patit si eu de-astea
Am deschis synaptic
mi-a detectat problema si mi-a rezolvat-o
edit-> fix broken packages

Incearca si asa. La mine a mers de fiecare data.
Si eu sunt incepator
smile

Offline

 

#5 05 Oct 2006 22:23:01

alecsx
Membru
Locaţie: Tg Mures
Înregistrat: 02 Mar 2006
Mesaje: 46
Site web

Re: Software index is Broken.....!

NU  reusesc  nici asa ......
The following problems were found on your system:
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

Exista vreo solutie  ....sau doar reinstalarea sistemului ??


[root@cust-rtr-idu-26 /]# kill bill
bash: kill: bill: arguments must be process or job IDs
-------------------------------------------------------------------
www.easyhowto.eu

Offline

 

#6 07 Oct 2006 17:50:27

Christmas
Membru
Locaţie: Bucuresti
Înregistrat: 10 Aug 2006
Mesaje: 136
Site web

Re: Software index is Broken.....!

Pai nu ai instalat YIM cu dpkg? Incearca:

Cod:

sudo dpkg -r ymessenger

Si apoi:

Cod:

sudo apt-get update
sudo apt-get -f install

Overhead the albatross hangs motionless upon the air...
TuxArena - Debian/Ubuntu/Mint Tutorials, News and Reviews
Intro Tutorials

Offline

 

#7 07 Oct 2006 19:34:09

ThunderM
Membru
Locaţie: Bucuresti
Înregistrat: 18 Jun 2006
Mesaje: 460

Re: Software index is Broken.....!

Iar daca si asta da gresi atunci incearca cu aptitude.


All experiments should be reproductible . They should always fail in the same way...

Offline

 

#8 09 Oct 2006 01:45:14

alecsx
Membru
Locaţie: Tg Mures
Înregistrat: 02 Mar 2006
Mesaje: 46
Site web

Re: Software index is Broken.....!

Pana la urma am reinstalat Ubuntu.Am incercat  si cu aptitude....insa fara a reusi ceva.Multumesc oricum


[root@cust-rtr-idu-26 /]# kill bill
bash: kill: bill: arguments must be process or job IDs
-------------------------------------------------------------------
www.easyhowto.eu

Offline

 

#9 09 Oct 2006 05:02:23

e.paiuc
Membru
Înregistrat: 09 Oct 2006
Mesaje: 37

Re: Software index is Broken.....!

se pare ca ai umblat in sources.list

unde ai pus adrese de debian -pur-  asa e ?

si eu am luat aceasta "plasa" ...
ce sa zic ...

decat halal compatibilitate  debian-ubuntu !!!

daca scap de reinstalare m-as bucura, mai fac incercari inca ...

Offline

 

#10 09 Oct 2006 05:31:26

e.paiuc
Membru
Înregistrat: 09 Oct 2006
Mesaje: 37

Re: Software index is Broken.....!

gata am rezolvat  - fara reinstalare ! -

pasii de urmat au fost 

1. descarcat de pe
http://mirror.switch.ch/ftp/mirror/ubun … n/g/glibc/

libc6_2.3.6-0ubuntu20_i386.deb

dupa care ...

2. root@p22:/# dpkg -i /home/ee/Desktop/libc6_2.3.6-0ubuntu20_i386.deb
(Reading database ... 79765 files and directories currently installed.)
Preparing to replace libc6 2.3.6.ds1-4 (using .../libc6_2.3.6-0ubuntu20_i386.deb) ...
Unpacking replacement libc6 ...
dpkg: warning - unable to delete old directory `/etc/ld.so.conf.d': Directory not empty
Setting up libc6 (2.3.6-0ubuntu20) ...
.....
adica sistemul a revenit la libc6 "stil "ubuntu ... uffff !!!  bine asta ...

Acum sa vedem daca merge si in continuarea...

3. root@p22:/# apt-get -f install
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  diakonos g++ g++-4.0 gcj gcj-4.1 irb1.8 libc6-dev libgcj-dev libgcj7-dev
  libgdbm-ruby1.8 libopenssl-ruby1.8 libreadline-ruby1.8 libruby1.8 libstdc++6-4.0-dev
  libtcltk-ruby1.8 libtool ruby1.8 zlib1g-dev
0 upgraded, 0 newly installed, 18 to remove and 1 not upgraded.
9 not fully installed or removed.
Need to get 0B of archives.
After unpacking 100MB disk space will be freed.
Do you want to continue [Y/n]?
(Reading database ... 79761 files and directories currently installed.)
Removing diakonos ...
Removing irb1.8 ...
Removing libtool ...
Removing libgdbm-ruby1.8 ...
Removing libopenssl-ruby1.8 ...
Removing libreadline-ruby1.8 ...
Removing libtcltk-ruby1.8 ...
Removing ruby1.8 ...
Removing libruby1.8 ...
Removing libstdc++6-4.0-dev ...
Removing gcj ...
Removing gcj-4.1 ...
Removing g++ ...
Removing g++-4.0 ...
Removing libgcj-dev ...
Removing libgcj7-dev ...
Removing zlib1g-dev ...
Removing libc6-dev ...
......
Super .... merge deci !

Si acum sa instalam ceea ce ne trebuie noua smile - apache2  -

4. root@p22:/# apt-get install apache2
Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
  apache2-common apache2-mpm-worker apache2-utils libapr0 ssl-cert
Suggested packages:
  apache2-doc
The following NEW packages will be installed:
  apache2 apache2-common apache2-mpm-worker apache2-utils libapr0 ssl-cert
0 upgraded, 6 newly installed, 0 to remove and 1 not upgraded.
Need to get 1256kB of archives.
After unpacking 4375kB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://ch.archive.ubuntu.com dapper/main libapr0 2.0.55-4ubuntu2 [132kB]
Get:2 http://ch.archive.ubuntu.com dapper/main ssl-cert 1.0.13 [9526B]
Get:3 http://ch.archive.ubuntu.com dapper/main apache2-utils 2.0.55-4ubuntu2 [91.6kB]
Get:4 http://ch.archive.ubuntu.com dapper/main apache2-common 2.0.55-4ubuntu2 [786kB]
Get:5 http://ch.archive.ubuntu.com dapper/main apache2-mpm-worker 2.0.55-4ubuntu2 [202kB]Get:6 http://ch.archive.ubuntu.com dapper/main apache2 2.0.55-4ubuntu2 [35.6kB]
Fetched 1256kB in 2s (419kB/s)
Preconfiguring packages ...
Selecting previously deselected package libapr0.
(Reading database ... 74278 files and directories currently installed.)
Unpacking libapr0 (from .../libapr0_2.0.55-4ubuntu2_i386.deb) ...
Selecting previously deselected package ssl-cert.
Unpacking ssl-cert (from .../ssl-cert_1.0.13_all.deb) ...
Selecting previously deselected package apache2-utils.
Unpacking apache2-utils (from .../apache2-utils_2.0.55-4ubuntu2_i386.deb) ...
Selecting previously deselected package apache2-common.
Unpacking apache2-common (from .../apache2-common_2.0.55-4ubuntu2_i386.deb) ...
Selecting previously deselected package apache2-mpm-worker.
Unpacking apache2-mpm-worker (from .../apache2-mpm-worker_2.0.55-4ubuntu2_i386.deb) ...
Selecting previously deselected package apache2.
Unpacking apache2 (from .../apache2_2.0.55-4ubuntu2_i386.deb) ...
Setting up libapr0 (2.0.55-4ubuntu2) ...

Setting up ssl-cert (1.0.13) ...

Setting up apache2-utils (2.0.55-4ubuntu2) ...
Setting up apache2-common (2.0.55-4ubuntu2) ...
Setting Apache2 to Listen on port 80. If this is not desired, please edit /etc/apache2/ports.conf as desired. Note that the Port directive no longer works.
Module userdir installed; run /etc/init.d/apache2 force-reload to enable.

Setting up apache2-mpm-worker (2.0.55-4ubuntu2) ...
* Starting apache 2.0 web server...                                              [ ok ]

Setting up apache2 (2.0.55-4ubuntu2) ...
............


Minunat ! am rezolvat-o  in <10' minute fara re-instalare .

Offline

 
Feed

Antet forum

Powered by FluxBB