Anunţ

Caută printre mesajele de pe forum înainte de a scrie unul nou!
Formulează corect întrebarea sau problema pe care o ai.
Respectă regulile forumului și Codul de Conduită!

#1 26 Aug 2016 21:23:24

Silviano007
Membru
Locaţie: Hunedoara
Înregistrat: 29 Apr 2013
Mesaje: 93

usb nefunctionale {Rezolvat }

Buna seara ! De curand mi-am schimbat placa de baza in intentia unui upgrade la PC. Placa de baza e Gigabite 970 G . Am instalat ubuntu 16.04 si windows 7...in dual boot.  Problema e ca usb-urile 2.0 de pe placa de baza sunt nefunctionale in linux si functionale in windows. usb-urile 3.0 sunt functionale dar din pacate nu am decat un stick compatibil cu usb 3.0. Cu comanda "lsusb" imi apar in terminal toate porturile, dar nimic conectat la ele. Din bios am activat tot ce tine de usb....si...nimic. A mai patit cineva asa ceva? Exista vreo rezolvare....minune? Multumesc !

Editat ultima oară de Silviano007 (27 Aug 2016 17:59:13)

Offline

 

#2 27 Aug 2016 08:42:30

shadow9063
Membru
Înregistrat: 28 Jun 2010
Mesaje: 318

Re: usb nefunctionale {Rezolvat }

Cu alta distributie ai incercat da vezi daca functioneaza ?
(live cd, live usb)


PC: Intel® Core™ i7-4790 CPU @ 3.60GHz × 8, 16 GB DDR3, Windforce GF GTX 660 1024 MB DDR5, Kingstone SV300S37A SSD 120GB + Samsung SSD 840 EVO 120GB + 2xWD Caviar Green 2TB + WD Caviar RED 3TB + WD Caviar Black 640GB
Linux Mint 17.3 + Linux Mint 17.2 Rafaela 64-bit

Offline

 

#3 27 Aug 2016 11:07:28

Silviano007
Membru
Locaţie: Hunedoara
Înregistrat: 29 Apr 2013
Mesaje: 93

Re: usb nefunctionale {Rezolvat }

Am incercat cu kubuntu 14.04 (live cd)...si aceeasi situatie. Mentionez ca imediat dupa butare in linux, pe un ecran negru imi apare o lunga lista de erori, toate legate de usb. Ceva de genul " error -32 usb device not accept adress...". Si totusi pe windows imi functioneaza toate, de aceea ma gandesc ca e problema de drivere, sau de kernel, desi si cu alt kernel e aceeasi situatie.

Offline

 

#4 27 Aug 2016 17:57:53

Silviano007
Membru
Locaţie: Hunedoara
Înregistrat: 29 Apr 2013
Mesaje: 93

Re: usb nefunctionale {Rezolvat }

Dupa 5 ore de sapat pe google am gasit rezolvarea. (nici o data nu am cautat atat pe google pentru ceva  smile )Se pare ca aceasta placa este din categoria "facute pentru windows", adica implementarea cipsetului SB970 de catre cei de la gigabyte este de asa maniera incat nici un kernel pe 64 de biti de la linux nu functioneaza optim cu el. Aceasta placa are parametrul "iommu" setat disable (default). pentru a functiona controlerul de la usb 2.0 trebuie dat "enable" acestui parametru. Bun, dar in acest caz nu mai functioneaza usb 3.0 si placa de retea . Pentru a fi din nou functionale se scrie un nou parametru in kernel, si anume "iommu=soft" si se da restart. Acum functioneaza toate si se vede o reducere semnificativa si a timpului de butare. Rezolvarea pentru cei care mai au o placa similara.

Offline

 

#5 28 Aug 2016 15:06:53

guletz2002
Membru
Locaţie: Brasov
Înregistrat: 09 Sep 2009
Mesaje: 1512

Re: usb nefunctionale {Rezolvat }

Vezi ca la unele placi de baza, in bios ai ceva legat de iommu (enable/disable). Poate de ai a trebuit sa modifici in setari, valoarea soft.


Daca retea Nu e, atunci nimic nu e !!!
LiCo : Proud GNU/Linux User since 2003.

Offline

 

#6 28 Aug 2016 19:58:46

Silviano007
Membru
Locaţie: Hunedoara
Înregistrat: 29 Apr 2013
Mesaje: 93

Re: usb nefunctionale {Rezolvat }

La placa mea cu iommu disable , cum era default, nu functionau usb-urile 2.0. Daca ii dadeam enable nu mai functionau cele 3.0 si placa de retea. Acum e enable, dar a trebuit sa scriu parametrul si in kernel. E  valabil la kernel pe 64 de biti. Am testat (live cd)cu ubuntu 14.04 pe 32 de biti si merge fara aceste modificari.

Offline

 

#7 22 Feb 2017 20:28:53

lupudepenet
Membru nou
Locaţie: Chinteni/Cluj
Înregistrat: 22 Feb 2017
Mesaje: 4
Site web

Re: usb nefunctionale {Rezolvat }

Aceeași problemă o am și eu pe un Gigabyte GA-990X-Gaming SLI, dar din păcate nu știu cum să rezolv problema cu scrierea parametrilor în kernel.M-ai putea ajuta cu niste detalii?.Eu folosesc Ubuntu 14.04.Mulțumesc anticipat.

Offline

 

#8 03 Mar 2017 20:16:15

Silviano007
Membru
Locaţie: Hunedoara
Înregistrat: 29 Apr 2013
Mesaje: 93

Re: usb nefunctionale {Rezolvat }

Nu stiu daca mai e de actualitate subiectul , dar iti pot spune cum am scris eu acest parametru, ca vad ca avem placi aproximativ asemanatoare. Eu am instalat "Grub customizer". Dupa ce il deschizi mergi la "general setings", si mai apoi la kernel parameters. Acolo pur si simplu mai adaugi un parametru "iommu=soft" (fara ghilimele). Apoi salvezi si dai restart sistemului, dar astea toate cu IOMMU trecut pe "enable" in bios. Default este dezactivat. Bafta !!!

Offline

 

#9 14 Sep 2018 11:46:20

danimur
Membru nou
Înregistrat: 26 Sep 2009
Mesaje: 8

Re: usb nefunctionale {Rezolvat }

Salut tuturor

Mi-am facut un pc nou:

Placa de baza: MSI B350
Procesor: Ryzen 5 2400g
Placa video: Nvidia G210
Hdd: 1Tb Sata WD
Ram: 16Gb frecventa 2133 real desi pe cutie  este imprimat 2666 MHz
Tastatura pe PS2 ( mai veche)
Mouse Logitec A4 optic

Am instalat Windows 10 pe 1 HDD fara sa intimpin  probleme.Totul functioneaza.
Am dorit sa instalez si Ubuntu 18.04 pe un al doilea HDD separat dar inca de la instalare nu aveam mouse. Greseala mea ca nu am incercat intii Linux si am dat instalare direct in urma a 10-12 instalari anterioare reusite  pe vechea configuratie ( cu procesor Intel)


Inainte de a se instala efectiv in linie de comanda mi-a aparut pentru scurt timp un mesaj prin care se specifica ca usb sunt cu probleme  mesaj care a disparut inainte sa il pot citi  pornind in scurt timp instalarea.

Am facut setarile de logare ignorind faptul ca nu am mouse din tastatura .

Cum pot rezolva aceasta problema?
Ma poate ajuta cineva?
Va rog.
Multumesc

Offline

 

#10 23 Sep 2018 19:58:25

Silviano007
Membru
Locaţie: Hunedoara
Înregistrat: 29 Apr 2013
Mesaje: 93

Re: usb nefunctionale {Rezolvat }

Am avut o problemă similară dar e vorba de alta placa de baza. Am rezolvat cum am specificat mai sus in acest topic. Vedeti daca sistemul instalat vede porturile usb cu comanda lsusb. Dacă da, puteti testa cu o versiune pe 32 de biti. Daca in acest caz functioneaza usb si implicit mouse-ul atunci e posibil sa fie eroare similara cu ce am avut eu.

Offline

 
Feed

Antet forum

Powered by FluxBB